формула в Ехсёl | eXcel 2007

формула в Ехсёl

Posted on admin 10.03.2011

Эта формула в Ехсёl выполняет следующую процедуру:

Обратите внимание на определение имен ДатаКнига и ГКСчет. ДатаКнига ссылается на ячейку $А$4, поскольку это — абсолютная ссылка (на это указывают два символа долла­ра), ДатаКнига возвращает одно и то же значение независи­мо от расположения ячейки, в которую она введена.

ГКСчет ссылается на ячейку $D5. Это смешанная ссыл­ка: зафиксирован только столбец, а строка может изменяться в зависимости от того, куда вводится ссылка на ГКСчет.

Поэтому формула:

= СУММ(ЕСЛИ(МЕСЯЦ(ДатаВвода) = МЕСЯЦ(ДатаКнига);1;0)* ЕСЛИ(НомерСчета = ГКСчет; 1 ;0)*ЖурналКредит

введена в ячейку F5 (см. рис.3). Но если формула введена в ячейку F6, она использует значение счета 22 (ячейка D6). Поскольку имя ГКСчет относится к смешанной ссылке $D5, оно само действует как смешанная ссылка.

С помощью этих формул все отдельные операции перено­сятся из Главного журнала в Главную книгу в соответствии со счетом, на который они были помещены, и с правильной датой текущей записи в главной книге.

Посмотрите в Главном журнале на статью Денежные сред­ства. Она используется как Кредит в трех местах, а по Дебету: для аренды офиса — 3206,5, заработная плата — 1200, и канцелярские товары – 10,39. Просуммируем вручную эти цифры:

3206,50
+1200,00
10,39
4416,89

А теперь посмотрим в Главную книгу на цифру, сто­ящую в ячейке по Кредиту, вы обнаружите то же значение — 4416,89. Это говорит о том, что наша система переноса значений из Главного журнала в Главную книгу работает безукоризненно.

Напомним, что в нашей системе работает принцип сбалансированности,т.е. во всех случаях сумма хозяйственной операции, отраженная по дебету и кредиту корреспондирующих счетов, должна быть одинакова. Чтобы убедиться в этом, посмотрим на ячейки F14 и E14. В ячейке Е14 стоит форму­ла:

=СУММА(Е5:Е13),

аналогичная стоит и в ячейке F14:

=СУММА(F5: F13),

а результаты этих сумм по дебету и кредиту одинаковы:

11041,27=11041,27.

Как видите, принцип сбалансированности тоже работает без сбоев.

Теперь изменим какое-то значение в любой ячейке Глав­ного журнала. Например, в ячейках Главного журнала D21 и Е21 заменим значение 1200 на 800 (предположим, двум ра­ботникам не выдана заработная плата по 200 грн., в сумме 400 грн.). Посмотрим, как на эти изменения прореа­гирует Главная книга. Она также изменит свое значение в ячейке Е12 на 800, а сумма баланса тоже изменится, но все равно будет такой же, как в Главном журнале:

10641,27=10641,27.

Если же попытаться провести эксперимент с изменени­ем даты в Главном журнале, скажем, в ячейке А22 дату 10.07.06, заменить на мартовскую — 10.03.06, то, перейдя на лист Главной книги в ячейке F5, вы обнаружите другую цифру: вместо известного нам числа 4416,89 мы увидим число 3216,89, и что самое приятное, в тех же ячейках Е14 и F14, будут стоять уже разные суммы: 10641,27 и 9441,27. В дан­ном случае сумма баланса подсказывает нам, что мы где-то допустили ошибку в Главном журнале, принцип сбаланси­рованности — нарушен!


Comments are closed.